Instalar Amarok 2.1 con todo y error GPG

Este problema no lo tenia con openSUSE (si, ya empiezo a extrañarlo). Es el clásico error de las llaves de Launchpad que se soluciona con linea de comandos.

Hace unos días los desarrollares de amaroK lanzaron la versión 2.1 del mejor reproductor que existe en Unix. Esta noticia ha inundado la “bloGNUsfera” y han repetido como “pericos” la misma noticia:

“Instala amarok agregando la siguiente línea al archivo /etc/apt/sources.list”

deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu jaunty main

Luego actualizas repositorios con apt-get update.

Lo bonito de esto es que arroja el error:

Leyendo lista de paquetes… Hecho
W: Error de GPG: http://ppa.launchpad.net jaunty Release Las firmas siguientes nose pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 2836CB0A8AC93F7A
W: Tal vez quiera ejecutar ‘apt-get update’ para corregir estos problemas

Bueno, ahí va una rudimentaria solución para instalar amarok 2.1:

gpg -keyserver keyserver.ubuntu.com -recv-keys 8AC93F7A && gpg –export -a 8AC93F7A >> key.asc

ACTUALIZACIÓN (25/Junio/2009)

Antes de las palabras keyserver y recv-keys se escribe un doble guión. Si solo ven uno en el post es debido al formateado de WordPress al momento de procesar los guiones continuos.

sudo apt-key add key.asc

Y listo, ahora hagan el “apt-get update” para actualizar repositorios. Después actualicen amarok con el comando:

sudo aptitude install amarok

Ahora ya tendremos listo amarok. Lo estaremos probando estos días y veremos su poder.

instantánea1

Espero que le sirva a los usuarios novatos y a los “bloggers” que repiten la noticia como “loros”.

Fuentes:

Un mundo libre

Ubuntips

Anuncios

9 pensamientos en “Instalar Amarok 2.1 con todo y error GPG

  1. ¡Eres grande! Jejeje

    Como bien dices, pocos blogs van más allá del copia-pega. Hacía tiempo que veía ese error, pues ese repositorio también sirve para actualizar KDE.

    Sin embargo, en mis repositorios (los de España) aun no está disponible la actualización, me resulta raro.

    Por cierto, ¿podrías comentar si notas diferencias de rendimiento con OpenSuse? Siempre se ha notado que Canonical deja un poco de lado a KDE respecto a Gnome, y he pensado muchas veces en probar OpenSuse. Me hecha para atrás que la gente se queje de sus repositorios, además de que no se encuentra tanta ayuda como para ubuntu.

    ¡Un saludo!

  2. @ Kamikaze_pum:

    Esos repositorios de Kubuntu Backports son independientes del servidor de España, cuando actualizas se descarga la pequeña base de datos de paquetes del repositorio según cada linea que existe en el archivo sources.list.

    En cuanto a comentar sobre el rendimiento de Kubuntu y openSUSE, eso lo haré en Papirux Magazine en su siguiente número, pero también lo postearé aquí.

    @ Deseos:

    Esperamos tus proximas visitas.

    @ chinarrista:

    Este post lo escribí molesto debido a que los “copy-bloggers” que no dan la información completa sobre este problema. Esto puede hacer que el usuario nuevo simplemente se arrepienta de seguir usando Kubuntu.

  3. Al copiar y pegar me devuelve esto:

    uso: gpg [opciones] [nombre_fichero]

    Habrá algun problema en la sintaxis del blog pero hay que sustituir el guion por doble guion. No basta con añadir uno, hay que sustituirlo

  4. Soy usuario Nuevo de Kubuntu. y linux en general a mi me sale el siguiente error Leyendo lista de paquetes… Hecho
    W: Error de GPG: http://ppa.launchpad.net jaunty Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 6D975C4791E7EE5E
    W: Error de GPG: http://ppa.launchpad.net jaunty Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 4874D3686E80C6B7
    W: Error de GPG: http://ppa.launchpad.net jaunty Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 2836CB0A8AC93F7A

    y no se como agregar “llaves Publicas =( ”

    y tambien tengo otro problema no se si me pueden ayudar no puedo sincronizar mi Philips GoGear en Kubuntu con ningún reproductor que puedo hacer ???????????

    • Esos errores son debido a que apt no tiene las llaves “para entrar” al repositorio. Hay programas gráficos que te ayudan a resolver el problema de las “keys” de launchpad. Por el momento no me acuerdo, solo busca en Google “script llaves lauchpad” y te deberá salir.

      Yo lo hago de una forma más rudimentaria mediante consola. Por cada error de esos:

      W: Error de GPG …… NO_PUBKEY 4874D3686E80C6B7

      Toma los últimos ocho dígitos que aparecen en la serie de números para lanzar otro comando:

      gpg –keyserver keyserver.ubuntu.com –recv-keys últimosOchoDígitos && gpg –export -a últimosOchoDígitos >> key.asc

      gpg --keyserver keyserver.ubuntu.com --recv-keys 6E80C6B7 && gpg –export -a 6E80C6B7 >> key.asc

      Ese comando solicita la llave al servidor de Ubuntu y la almacena en un archivo llamado key.asc. El archivo se crea solito y es recomendable que cada vez que lances el comando pongas otro nombre como: “otraJKey” o “keyRepo”, etc.

      Simplemente después agregas la llave con:

      sudo apt-key add nombreDelArchivo.asc

      Por lo de tu celular no tengo idea, cuando tenía mi Moto Rokr E2 todo lo manejaba por modo de transferencia de archivos USB.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s